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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to Icepak for beginners and advanced
users. It includes instructions to create and use a Reduced Order Model (ROM) using Ansys Ice-
pak and Ansys Twin Builder.

There are two steps to create ROMmodel:

l Create the step response files. These files can be created automatically using Icepak.
This tutorial demonstrates how to create the required step response files in Icepak.

l Create the ROM in Twin Builder. This tutorial also presents the procedure needed to cre-
ate a state-space model in Twin Builder.

This chapter contains the following topic:
l "Sample Project" below

Sample Project
In this project, we have four FET’s (Field-effect transistor) placed on a board and a heat sink
mounted on one of the FET. These FET’s generate heat which gets dissipated into the envir-
onment. Forced convection is used for thermal management of the system.

Figure 1-1: Sample Project

We are interested in temperature rise at the four FET’s due to its power dissipation. From a sys-
tem point of view, power dissipation from the FET’s are the inputs and the temperature rise at the
four FET’s are the outputs. We will create a ROMwhich can efficiently calculate temperatures at
the pre defined outputs under any transient heat dissipation scenario.

The state-space approach is generally valid for linear systems consisting of forced convection
flow and insignificant radiative heat transfer.
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2 - Prepare and Run the Icepak Para-
metric Trials

This chapter contains the following topics:
l Open the Project
l Assign Boundary Conditions
l Create the LTI ROM Parametric Setup
l Review the Toolkit Output
l Run the Parametric Setup
l Export the LTI ROM

Open the Project
This chapter contains the following topics:

l Launch the Ansys Electronics Desktop
l Set 3D UI Options

Launch the Ansys Electronics Desktop
A shortcut of the Ansys Electronics Desktop application appears on your desktop once the applic-
ation is installed.

1. On the Desktop ribbon tab, click Open Examples. Then:
a. In theOpen dialog box that appears, click the parent folder icon ( ) once to move

up one level above the Examples folder.
b. Double-click the Help folder and then the Icepak folder.
c. Select the file Icepak_TwinBuilder.aedt and clickOpen.

2. The model is displayed in the 3D Modeler window.
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Figure 2-1: Field-effect transistors model in the 3D Modeler window

3. From the Filemenu, select Save As, and save the project in the desired working dir-
ectory.

Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:

Prepare and Run the Twin Builder Analysis 2-2
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3. ClickOK.

Assign Boundary Conditions
Assign block thermal boundary conditions to the FET objects.

Prepare and Run the Twin Builder Analysis 2-3
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1. In the History tree, right-click on FET1 and select Assign Thermal > Block.

2. In the Block Thermal Model dialog box, enter FET1 for the Name.
3. Retain the default settings and clickOK.
4. Repeat steps 1 through 3 for FET2, FET3, and FET4, naming the boundary conditions

accordingly. The boundary condition assignments appear under Thermal in the Project
Manager.
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Create the LTI ROM Parametric Setup
Run the LTI ROM Parametric Setup toolkit to generate the parametric trials.

1. From the Icepak > Toolkit > Modelingmenu, select LTI_ROM_Parametric_Setup.
2. In the LTI ROM Parametric Setup dialog box, do the following:

l Note the default Input andOutput selections.
l Note the design's solution setup is already selected in the Select Transient Setup
drop-down list.

l Select Create steady state design and link with transient setup.
l For Input Object Power, retain the default 5W power value.
l Click Create Setup. The toolkit generates the LTI ROM output.

Prepare and Run the Twin Builder Analysis 2-5
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Review the Toolkit Output
Review the project items generated by the LTI ROM Parametric Setup toolkit.

1. In the Project Manager, note that the steady state design with the corresponding bound-
ary conditions has been added to the project.

2. In the original transient design, note that block boundary conditions' Total Power values
are now assigned a variable.
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3. Note that monitor points have been added underMonitor.

4. In the transient design, expand Analysis and double-click Setup1. The solve setup has
been set to run the transient from 0 to 10000 seconds.

Prepare and Run the Twin Builder Analysis 2-8
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5. Click Advanced next to Time Step. The toolkit generated a dataset and assigned it as the
piecewise constant variation function. As time increases, the time step size increases, so
fewer steps are run as time progresses in the transient simulation.
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6. On the Solver Settings tab, the toolkit enabled the Start/Continue from a previously
solved setup and Frozen flow simulation check boxes and linked to the steady state
design.
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7. In the Project Manager underOptimetrics, the toolkit added the parametric metric setup.
Double-click ParametricSetupROM. In the Setup Sweet Analysis dialog box Table tab,
note the four trials with one field-effect transistor assigned 5W total power value for each
trial.

Prepare and Run the Twin Builder Analysis 2-11
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Run the Parametric Setup
1. In the Project Manager underOptimetrics, right-click ParametricSetupROM and select

Analyze.
2. In the Project Manager under Analysis, right-click Setup1 and select Thermal Monitor

to display the temperature results.
3. In the Solutions dialog box, click the Design Variation [...] button.
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4. In the Set Design Variation, select a row and clickOK to plot the monitor point data.

Export the LTI ROM
1. From the Icepakmenu, select Export ROM > LTI ROM.
2. In the Export LTI ROM dialog box, note the default selections.

Prepare and Run the Twin Builder Analysis 2-13
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3. If needed, select a different Export Directory.
4. Click Export to export the solutions. This completes the generation of the step response

data using Icepak. In the next section you will use the step response data to create a
state-space model in Twin Builder.

Prepare and Run the Twin Builder Analysis 2-14
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3 - Prepare and Run the Twin Builder
Analysis

This chapter contains the following topics:
l Run Thermal Model Identification
l Build the Twin Builder Model
l Run the Analysis and Plot the Outputs

Run Thermal Model Identification
In Twin Builder, create a ROMmodel from the Icepak data.

1. From the Projectmenu, select Insert Simplorer Design.
2. From the Twin Buildermenu, select Toolkit > Thermal Model Identification.
3. In the Thermal Model Identification dialog box, do the following:

l Number of Inputs: Enter 4.
l Number of Outputs: Enter 4.
l Response/Input File Location: Click Browse and select the directory in which you
exported the data from Icepak. The directory is appended with _TwinBuild-
erFiles.

Getting Started with Icepak®: LTI ROM
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l ClickGenerate.
4. A command prompt appears. Press any key to continue to generate the ROMmodel.

Prepare and Run the Twin Builder Analysis 3-2
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5. In the Complete dialog box, clickOK.

6. In the Thermal Model Identification dialog box, click Close.

Build the Twin Builder Model
Insert the thermal ROM component and build the model.

Place the ROM in Twin Builder
1. In the Project Manager, double-click the Simplorer1 design to ensure it is the active

design.
2. Expand Definitions > Components.
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3. Select Thermal_ROM_SML and drag it into the 3D Modeler window. Click again to place
the component and the press Esc to exist the component placement mode.

Prepare and Run the Twin Builder Analysis 3-4
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Enable Outputs
1. From the Twin Buildermenu, selectOutput Dialog.
2. In theOutput Dialog, expand Thermal_ROM_SML1 and select the four outputs listed.

3. Click Close.

Specify Inputs
Place Source and Time Function Blocks

Note:

If the Component Libraries window is not displayed, click View > Component Librar-
ies.

1. On the Components tab of the Component Libraries window, expand Simplorer Ele-
ments > Basic Elements > Blocks > Sources Blocks.

2. Click and drag CONST: Constant Value to the workspace. Click again to place the block.

Prepare and Run the Twin Builder Analysis 3-5
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3. Place two more CONST: Constant Value blocks in the workspace.
4. Press Esc to exit placement mode.
5. Connect the blocks to the inputs as displayed in the following image.

6. In the Component Libraries window, expand Simplorer Elements > Basic Elements >
Tools > Time Functions.

7. Click and drag TRAPEZ: Trapezoidal Wave to the workspace. Release the mouse button
to place the block.

8. Connect the block to input4_fet4.
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Specify Input Parameters
1. Double-click the CONST1 block to open its Parameters panel.
2. Under Parameters next to Value, enter 1.5 to specify the power dissipation (in Watts) for

the ROM and clickOK.
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3. Repeat Step 2 for CONST2 and CONST3.
4. Double-click the TRAPEZ1 block to open its Parameters panel. Enter the values as dis-

played in the following image.

Run the Analysis and Plot the Outputs
Specify Settings and Run the Analysis

1. In the Project Manager, expand Analysis.
2. Double-click on TR solution setup.
3. In the Transient Setup Analysis dialog box, do the following:

l End Time - Tend: Enter 1000 s.
l Min Time Step - Hmin: Enter 0.1 s.
l Max Time Step - Hmax: Enter 4 s.

Note:

Ensure that you select seconds as the unit for the three entries.

Prepare and Run the Twin Builder Analysis 3-8
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4. Click OK.
5. Right-click the TR solution setup and select Analyze.

Plot the Outputs
1. In the Project Manager, right-click Results and select Create Standard Report > Rect-

angular Plot.
2. In the Report dialog box, select all four outputs as shown in the image below.
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3. Click New Report and then Close.
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